Discussion:
Checksum error in Vista
(too old to reply)
Morris
2010-04-11 16:00:51 UTC
Permalink
Raw Message
I have some UDP p2p application that works fine in most enviroments but one-
in a Wiindows Vista. In this PC I have a VMware software and I run instances
of the application under Windows Vista and also under any instance of the
virtual machines(WIndows XP).
Communicating instances in the virtual machines work fine, while on the
other hand communicating between the Vista instance and any other virtual
machine instance causes checksum error in the virtual machine(as seen with
Wireshark).
Connecting another XP machine to the network card and running the
application ends up with similar results, i.e. works fine with any virtual
machine but fails with checksum error if working "against" the Vista
instace.
Has anyone any idea how to debug it?
Regards
Morris
Morris
2010-04-11 16:30:38 UTC
Permalink
Raw Message
In the previous post I forgot to say that some aspects of the communication
between the Vista and the virtual machines do work fine. For instance, I can
ping from both directions and also copy&paste files. Only my specific UDP
application causes problems as described in the previous post.
Thanks for any idea...
Morris
Post by Morris
I have some UDP p2p application that works fine in most enviroments but one-
in a Wiindows Vista. In this PC I have a VMware software and I run instances
of the application under Windows Vista and also under any instance of the
virtual machines(WIndows XP).
Communicating instances in the virtual machines work fine, while on the
other hand communicating between the Vista instance and any other virtual
machine instance causes checksum error in the virtual machine(as seen with
Wireshark).
Connecting another XP machine to the network card and running the
application ends up with similar results, i.e. works fine with any virtual
machine but fails with checksum error if working "against" the Vista
instace.
Has anyone any idea how to debug it?
Regards
Morris
Loading...