Discussion:
Multicast stop getting data after 240 seconds
(too old to reply)
Chiyu Wang
2010-03-11 14:31:01 UTC
Permalink
Raw Message
I wrote a UDP multicast application and it stops after 240 seconds in windows
xp. But it works fine in windows vista and windows 7. In our network, we are
using IGMP snooping. So If I turn off the igmp snooping, my programm will
work too. But we need to turn it on, in order not to disturb wireless network.

I also tried the multicast in VLC player and quicktime, and they do not work
in windows xp either and only work in windows vista and windows 7.

If I use VLC both as sender and receiver, it will work.

So I think there is something strange in my code. Maybe only a setting
affect it.

Is any one can give me some suggestions? Thanks.
vasanth
2010-03-12 13:09:02 UTC
Permalink
Raw Message
What is your multicast group?
Post by Chiyu Wang
I wrote a UDP multicast application and it stops after 240 seconds in windows
xp. But it works fine in windows vista and windows 7. In our network, we are
using IGMP snooping. So If I turn off the igmp snooping, my programm will
work too. But we need to turn it on, in order not to disturb wireless network.
I also tried the multicast in VLC player and quicktime, and they do not work
in windows xp either and only work in windows vista and windows 7.
If I use VLC both as sender and receiver, it will work.
So I think there is something strange in my code. Maybe only a setting
affect it.
Is any one can give me some suggestions? Thanks.
Loading...